«前の日記(2009-07-12) 最新 次の日記(2009-07-16)» 編集

meta's blog - The Power To Serve

筆者について

FreeBSDを通じてOSSにささかな貢献を。

OSS活動をご支援いただける方を募集しています


2009-07-14 クラウドコンピューティング

iPhone のアドレス帳を OpenLDAP で管理する (OpenLDAP導入編)

なんでもオンラインで管理したい病なのでやっちゃいましょう。

サーバは基本的に FreeBSD です。

まず、OpenLDAP Server をインストールします。

# cd /usr/ports/openldap24-server && make install

次に /etc/rc.conf の編集。

# echo 'slapd_enable="YES"' >> /etc/rc.conf

/usr/local/etc/openldap/slapd.conf を編集。とりあえず書き換えるのは以下のところくらい。

suffix          "dc=thelefty,dc=org"
rootdn          "cn=Manager,dc=thelefty,dc=org"
rootpw          {SSHA}aKeZVecq39wD/EVQiSVzxRsuAVMqqOE8

rootpw は slappasswd で生成します。

$ slappasswd
New password:
Re-enter new password:
{SSHA}R2h4fgMhbwZk7hb1ARyBJvuJeLqVSUhC

そして、slapd を起動。

# /usr/local/etc/rc.d/slapd start
Starting slapd.

LDAPのツリーを作成します。以下のような内容のファイルを作成。

dn:dc=thelefty,dc=org
objectClass:organization
objectClass:dcObject
o: thelefty.org address book

dn: ou=AddressBook,dc=thelefty,dc=org
objectClass: organizationalUnit
ou: AddressBook

そして登録。

$ ldapadd -x -D cn=Manager,dc=thelefty,dc=org -W -f $INPUTFILE

登録されているか確認します。上のファイルの内容に似たものが出てくればOKです。

$ ldapsearch -x -W  -D cn=Manager,dc=thelefty,dc=org -b dc=thelefty,dc=org
Enter LDAP Password:

とりあえずこれでLDAPサーバ側の準備は完了。アクセス制限やSSLでの暗号化設定はまたの機会に。